Barracuda Appliance Control : Configuration Backup to Cloud – Service Disruption

Incident Report for Barracuda Networks

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jan 30, 2026 - 16:35 UTC

Identified

The root cause for the incident has been identified, and remediation changes are now in place.
Posted Jan 30, 2026 - 07:58 UTC

Investigating

We are aware that some customers are encountering cloud backup failures with the message “File upload failed.”The Barracuda team is investigating this issue and working to deliver a resolution for the same at the earliest.

Affected services:
Cloud backups
Posted Jan 29, 2026 - 12:08 UTC
This incident affects: Appliance Control (Cloud backups).