BCAS: Mail processing partial outage in UK region

Incident Report for Barracuda Networks

Resolved

All customer impact has been resolved and mail processing is fully restored for all customers in the region.
Posted Mar 29, 2026 - 15:18 UTC

Update

We are continuing to restore service. The number of affected customers in the region is now below 10%.
Posted Mar 28, 2026 - 11:11 UTC

Identified

The issue has been identified and our engineers are working with operations staff to restore services.
Posted Mar 28, 2026 - 10:55 UTC

Investigating

Mail processing may be impacted for up to 15% of customers in the UK region. Affected customers may experience a delay in new mail processing until service is restored.
Posted Mar 28, 2026 - 10:53 UTC
This incident affected: Cloud Archiving Service (Mail Processing).