Email Gateway Defense - Mailflow in the UK and DE are experiencing high deferral rates.

Incident Report for Barracuda Networks

Resolved

This incident has been resolved.
Posted 2 months ago. Jan 27, 2025 - 12:26 UTC

Monitoring

We have identified the problem, deferral rates are returning to normal, we're currently monitoring the situation.
Posted 2 months ago. Jan 27, 2025 - 10:47 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted 2 months ago. Jan 27, 2025 - 10:25 UTC

Investigating

We are currently investigating this issue.
Posted 2 months ago. Jan 27, 2025 - 10:14 UTC
This incident affected: Email Gateway Defense (Mail Delivery).
DeutschEspañolFrançaisItaliano日本語中文(简体)
Powered by Localize
English