Barracuda XDR - Service Disruption

Incident Report for Barracuda Networks

Resolved

Our engineering team has resolved this issue and monitored the process to ensure the ingestion process is fully operational.
Posted Mar 07, 2025 - 00:19 UTC

Monitoring

Our engineering team has identified the cause of this issue and implemented a solution. We will continue to monitor to ensure the impacted process is fully operational.
Posted Mar 06, 2025 - 04:10 UTC

Identified

Barracuda XDR is currently experiencing an issue in the background process which results in the delayed events ingestion of some of integration datasources into our platform. Our engineers have identified the cause and are currently working on resolving this process degradation issue. We understand the impact this may have on your business and are committed to restoring this process to fully operational as quickly as possible.

The core XDR service is not affected. Data is still flowing into XDR and the SOC's systems are fully operational. We will provide further updates as we implement a solution.
Posted Mar 05, 2025 - 20:47 UTC
This incident affected: XDR (XDR Service).