Barracuda Cloud-to-Cloud Backup Service Degradation (Global)

Incident Report for Barracuda Networks

Resolved

This incident has been resolved.
Posted Sep 05, 2025 - 12:41 UTC

Update

The degradation of service caused a delay in some scheduled job processing, and may have generated errors or warnings on job reports that will resolve during the next attempt to backup, restore or export.
Posted Sep 04, 2025 - 21:13 UTC

Monitoring

A fix has been implemented, and we are monitoring the results.
Posted Sep 04, 2025 - 18:35 UTC

Identified

The issue has been identified, a fix has been implemented, and services are beginning to recover.
Posted Sep 04, 2025 - 18:00 UTC

Update

We are continuing to investigate this issue.
Posted Sep 04, 2025 - 14:47 UTC

Investigating

We are investigating an issue with Cloud-to-Cloud Backup. Users may not be able to access the product user interface and may experience long-running or failed jobs.
Posted Sep 04, 2025 - 14:46 UTC
This incident affected: Cloud to Cloud Backup (Web Interface, Office 365 Integration, Cloud to Cloud Backups).