Barracuda Cloud Archiving Service - mas.eu.barracudanetworks.com Outage beginning 1/11/2018 16:30 UTC
Incident Report for Barracuda Networks
Resolved
This incident has been resolved.
Posted Jan 11, 2018 - 17:56 UTC
Identified
Customers are unable to access mas.eu.barracudanetworks.com. Barracuda first started seeing this outage at 1/11/2018 16:30 UTC. Barracuda Engineering is aware and is working to restore full functionality for all customers.

Affected services:
Barracuda Cloud Archiving Service - EU region only
Posted Jan 11, 2018 - 17:37 UTC
This incident affected: Cloud Archiving Service (Web Interface, End-user Access, Mail Processing, Exchange Integration, PST Import).