Mail Processing Delays in the US for Cloud Archiving Service
Incident Report for Barracuda Networks
Update
All Cloud Archiving Service customer emails from the period of this outage are now indexed and available for search.
Message Archive appliance customers using the hybrid option to archive their messages in the cloud may see some messages missing. We are continuing to make progress on indexing those items.
Posted Jul 23, 2021 - 23:39 UTC
Update
We have completed processing mail for Cloud Archiving Service customers and mail should be available for the affected time periods.

We are now working on indexing the mail from the Cloud Connected Appliance customers. We will provide an ETA for these customers as soon as it is available.
Posted Jul 21, 2021 - 15:26 UTC
Update
We have been able to successfully accelerate the indexing process to make them available for search. Affected messages have been queued for processing and no data has been lost. At the current rate we estimate that all items will be available by end of day Wednesday July 21. We will provide another update if the estimated completion date changes.
Posted Jul 19, 2021 - 20:54 UTC
Update
Some customers are presently unable to search and mail processing will be delayed for mail received after July 15 for those select customers. Additionally, we are still processing items received between April 6 and May 19 for a prior incident
Posted Jul 16, 2021 - 20:26 UTC
Update
New emails are being indexed for search. Pending items from June 19 to June 29 are also being processed in the background. Some customers are presently unable to search and mail processing will be delayed for mail received today for those select customers.
Posted Jul 15, 2021 - 17:43 UTC
Update
We have performed maintenance to reduce the likelihood of similar incidents recurring in the future. Pending items from June 19 to June 29 are still being processed in the background.
Posted Jul 12, 2021 - 22:32 UTC
Update
We have taken additional corrective action by deploying additional infrastructure to the affected service. New emails are being indexed for search. Pending items from June 19 to June 29 are also being processed in the background. We continue to monitor progress and will provide updates as available.
Posted Jul 09, 2021 - 13:20 UTC
Update
We are observing a positive impact after the configuration change in the cluster. New emails are now being indexed for search. Pending items from June 19 to June 29 are also being processed in the background. We continue to monitor progress and will provide updates as available.
Posted Jul 01, 2021 - 19:00 UTC
Update
Our engineers are currently working on tuning a configuration setting in the affected cluster hosting our email search infrastructure. We expect that to help with indexing emails since 6/19 and make it available for search.
Posted Jun 30, 2021 - 15:26 UTC
Update
We've determined that the outage from the weekend of June 19-20, 2021 caused delayed processing even for items received after the weekend and continues to affect newly received items for some customers. All items received since June 19 have been stored, and we're working on making them available in search results.
Posted Jun 28, 2021 - 16:52 UTC
Update
Over the weekend of June 19-20, 2021, we experienced a brief service outage. Our engineering team have identified the issue and are working to process mail received over the weekend. There will be no data loss as a result of this incident.
Posted Jun 22, 2021 - 15:00 UTC
Update
Newly archived items are now available for all customers. Mail received between April 6, 2021 and May 19, 2021 has been received and is being processed. We'll continue to provide updates along with an estimate when we're able.
Posted May 20, 2021 - 15:02 UTC
Update
Most mail received prior to April 6, 2021 has been received and is currently available for search, and we're working to make the remaining items available. Items received during the time of the incident are safely stored and will become available as we process them. We'll continue to provide updates along with an estimate when we're able.
Posted Apr 20, 2021 - 01:46 UTC
Update
We are continuing to work on the rebuild of the indexes though progress has been slower than expected. We are still expecting mail that was archived before last week to be available within the next 24 hours.
Posted Apr 15, 2021 - 00:31 UTC
Update
Our Engineering team is working on rebuilding some of the indexes for archived mail. Any mail that was archived before last week will be searchable within the next 24 hours.

Any mail that was archived within the last week is still being re-indexed. We will provide an estimated time for resolution as soon as it is available.
Posted Apr 12, 2021 - 20:24 UTC
Update
We are continuing to work on resolving the issue. We will share additional information with you as soon as it becomes available.
Posted Apr 09, 2021 - 14:34 UTC
Identified
Some Cloud Archiving customers in the US may experience delays in new archived email appearing in search results. We have identified the issue and are working to restore service to normal operating levels. At this time we expect the issue to be resolved within the next 24 hours.
Posted Apr 07, 2021 - 19:09 UTC
This incident affects: Cloud Archiving Service (Mail Processing).