Re-delivery delays for ESS US region
Incident Report for Barracuda Networks
Resolved
We have confirmed that service has been fully restored. Please contact support if you experience any further issues.
Posted Feb 11, 2019 - 18:35 UTC
Update
We have fixed the problem however there is a backlog of re-delivery items that that our systems need to process. Our engineers are monitoring this process and we will send another update once the service is back to normal.
Posted Feb 08, 2019 - 23:44 UTC
Monitoring
We have fixed the issue and are monitoring the email security service closely.
Posted Feb 08, 2019 - 21:11 UTC
Investigating
Barracuda is aware of delays in redelivering messages from the UI for customers using the US region. We are working on addressing the issue.
Posted Feb 08, 2019 - 19:53 UTC
This incident affected: Email Gateway Defense (User Interface).