Barracuda Cloud Archiving (BCAS) Maintenance - Delayed Mail Processing EU Region (Migrated Tenants Only)
Incident Report for Barracuda Networks
Resolved
This incident has been resolved.
Posted Jan 08, 2025 - 19:40 UTC
Update
The issue has been resolved. Please note: It may take up to 24-48 hours to process the backlog.
Posted Jan 08, 2025 - 19:40 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jan 08, 2025 - 13:24 UTC
Identified
The issue has been identified and we are working on a fix. In the meanwhile, please keep in mind that all of your data is being ingested in real time, only the processing is delayed. We appreciate your patience.
Posted Jan 08, 2025 - 00:07 UTC
Investigating
Mail processing is delayed in the AWS EU region affecting switched tenants. Mail is still being ingested, and all data will be available once resolved.
Posted Jan 07, 2025 - 20:48 UTC
This incident affected: Cloud Archiving Service (Mail Processing).