Cloud Archiving Service (US Region): Email Processing Delays
Incident Report for Barracuda Networks
Resolved
This issue has been resolved and email processing continues to work normally. We thank you for your patience while we worked to resolve this issue. Please have a great day.
Posted Feb 07, 2024 - 17:11 UTC
Monitoring
We have implemented a fix and are currently monitoring the service for any further issues. Thank you for your patience.
Posted Feb 06, 2024 - 22:46 UTC
Investigating
We are currently investigating delayed email processing in our US region and will provide further updates as they become available.
Posted Feb 06, 2024 - 19:43 UTC
This incident affected: Cloud Archiving Service (Mail Processing).