Barracuda XDR - Service Disruption on signals detection

Incident Report for Barracuda Networks

Resolved

This incident has been resolved, and the threat detection is now fully operational
Posted Jul 29, 2026 - 17:55 UTC

Monitoring

Barracuda XDR experienced an intermittent disruption in signal detection following the rollout of changes to SIEM rule enrichment earlier this morning (UTC). As a result, alert generation may have been delayed across all regions. Our engineering team promptly identified the underlying cause and implemented the appropriate corrective actions to restore normal functionality. We will continue to closely monitor the environment to ensure ongoing stability and the full restoration of expected operational performance.
Posted Jul 29, 2026 - 16:16 UTC
This incident affected: XDR (XDR Service).