XDR Dashboard blocks with error checking SSO account

Incident Report for Barracuda Networks

Resolved

The incident has been resolved and root cause investigation is proceeding.
Posted Sep 01, 2026 - 00:48 UTC

Investigating

We are investigating the cause of this issue.
Posted Aug 31, 2026 - 23:25 UTC
This incident affected: XDR (XDR Dashboard).