Reports of problems with outbound mailflow - US Region

Incident Report for Barracuda Networks

Resolved

This incident has been resolved.
Posted Sep 19, 2023 - 22:53 UTC

Monitoring

A fix has been implemented and we are monitoring the situation.
Posted Sep 19, 2023 - 21:38 UTC

Investigating

We're getting some reports of issues with outbound mail flow in the US region and are investigating.
Posted Sep 19, 2023 - 21:05 UTC
This incident affected: Email Gateway Defense (Mail Delivery).