Barracuda Cloud Archiving (BCAS) Maintenance - Delayed Mail Processing EU Region (Migrated Tenants Only)
Incident Report for Barracuda Networks
Resolved
This incident has been resolved.
Posted Jan 14, 2025 - 23:20 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jan 14, 2025 - 19:36 UTC
Identified
The issue has been identified and we are working on a fix. In the meanwhile, please keep in mind that all of your data is being ingested in real time, only the processing is delayed. We appreciate your patience.
Posted Jan 14, 2025 - 15:49 UTC
This incident affected: Cloud Archiving Service (Mail Processing).