Barracuda Cloud-to-Cloud Backup - Degraded Backup Performance (UK Region)

Incident Report for Barracuda Networks

Resolved

This incident has been resolved.
Posted Mar 24, 2023 - 19:35 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 24, 2023 - 19:05 UTC

Investigating

We are currently investigating an issue causing slower than normal backup performance and slow account provisioning.
Posted Mar 24, 2023 - 17:46 UTC
This incident affected: Cloud to Cloud Backup (Web Interface, Cloud to Cloud Backups).