We are continuing to verify the maintenance items.
Posted Jul 19, 2025 - 03:59 UTC
Verifying
Verification is currently underway for the maintenance items.
Posted Jul 19, 2025 - 03:57 UTC
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jul 19, 2025 - 03:30 UTC
Update
We will be undergoing scheduled maintenance during this time.
Posted Jul 12, 2025 - 05:06 UTC
Scheduled
We will be undergoing scheduled maintenance on the Barracuda Appliance Controller (BAC) during this time. As part of this effort, we will implement infrastructure improvements to enhance overall system performance and efficiency. Queries that require significant resources on specific instances will be optimized to minimize the load and enhance stability, while resource allocations will be modified to boost service quality. The maintenance window is expected to last no more than one hour. We appreciate your understanding and will ensure minimal disruption during this period.
Posted Jul 12, 2025 - 05:01 UTC
This scheduled maintenance affected: Appliance Control (Web Interface, Device Connections, Cloud backups).